ANSWERED

OrderRequestCustomerInfo tipo de dato

estoy implementando una app en flutter, e agregado su paquete conekta conekta 6.0.4 ya e logrado crear clientes y traer datos, ahora intento crerar ordenes, pero segun la documentacion el tipo de dato solicitado en customerInfo de OrderRequest es un OrderRequestCustomerInfo, pero me marca error pidiendo un OrderRequestCustomerInfoBuilder, pero este no contiene parametros de cliente , nombre etc
ANSWERED

ubicación de archivos

Acabo de descargar los archivos de github y leyendo los pasos dice que debo incluir endor/autoload.php' pero buscando en los archivos no los localizo, me podrían indicar en donde los ubico o bien si los debo de crear. Gracias.
ANSWERED

error

Error: [401] Client error: `POST https://api.conekta.io/orders` resulted in a `401 Unauthorized` response: {"details":\[{"debug_message":"Unauthorized access, please check the permissions of your key for this call.","message":"A (truncated...) porque me da este error?
ANSWERED

Tarjetas Fintech

Buen día, tengo una duda, estamos habilitando el pago con tarjetas en nuestro sistema, para hacer publico a nuestros clientes, queremos conocer si este tipo de tarjetas son aceptadas por parte del sistema de conekta. Con esto me refiero a tarjetas como son Nu, Vexi, Spin by Oxxo, Klar, etc, tengo entendido que este tipo de tarjetas, en su mayoría tienen un respaldo por parte de American Express, Visa y Mastercard, pero quería confirmar con ustedes que no haya detalles con este tipo de tarjetas, verifique en el apartado de Bancos Compatibles <https://help.conekta.com/hc/es-419/articles/360018089974-Bancos-Compatibles>, pero no menciona algo respecto a este tema.
ANSWERED

API red ALterna

hola, tengo esta guía que es estupenda https\:// developers.conekta.com/page/pagos-con-oxxo-pay-recurrente pero no encuentro la que debo usar para que mis clientes puedan usar la Red Alterna ya que hay lugares de mis clientes donde no hay OXXO
ANSWERED

No me permite agregar tarjetas API CONEKTA +FLUTTER

Future <void> main() async{ var instance = Conekta(); instance.setBearerAuth("bearerAuth", "key_xxxx"); final api = instance.getTokensApi(); final Token token = Token( card: TokenCard( name: 'Alfonso Osorio', number: '4242424242424242', cvc: '847', expMonth: '12', expYear: '2040', ), ); // Token | requested field for token final String acceptLanguage = 'es'; // String | Use for knowing which language to use try { final response = api.createToken(token:token as Token, acceptLanguage:acceptLanguage); print(response); } catch (e) { print('Exception when calling TokensApi->createToken: $e\\n'); } } Sí obviamente sé, que tengo que poner la API Key. La pongo y me manda estos errores. Me estoy guiando de la documentación oficial. ![](https://files.readme.io/5a12abe-imagen.png) Cómo puedo solucionar este error? Muchas gracias.

Aceptan tarjetas internacionales?

Puedo poner el precio de mis productos en dólares y aceptar pagos en tarjetas extranjeras?
ANSWERED

Creación de TOKEN con Flutter

Me sale este error cuando trato de crear un token Future <void> main() async{ var instance = Conekta(); instance.setBearerAuth("bearerAuth", "key_xxxxxx"); final api = instance.getTokensApi(); final Token token = Token(); // Token | requested field for token final String acceptLanguage = 'es'; // String | Use for knowing which language to use try { final response = api.createToken(token:token, acceptLanguage:acceptLanguage); print(response); } catch (e) { print('Exception when calling TokensApi->createToken: $e\\n'); } } ![](https://files.readme.io/4279332-imagen.png)
ANSWERED

FLUTTER + CONEKTA API

tengo este error con conekta y flutter - Me aparece que debo instalar conekta:^6.0.0-beta.2, la cosa es que no funciona por que sale error en un regex. Intento instalar la versión 6.0.2 y aparece este error: Because every version of flutter_test from sdk depends on meta 1.10.0 and conekta >=6.0.0 depends on meta 1.9.1, flutter_test from sdk is incompatible with conekta >=6.0.0.
ANSWERED